Device Compatibility

Check if your smartphone and tablet are compatible with SenzeBand 2 and Neeuro's apps

Compatibility Requirements

Our apps can be used on Android or iOS devices with the following specifications:

  • Bluetooth 5
  • Minimum of 4GB RAM
  • Apple iOS 13.0 and above
  • Android 8 and above

The following devices are NOT recommended due to some compatibility issues:

  • Samsung Galaxy Tab Lite Series

Here are some recommended devices:

Tablets

iOS

  • iPad (10th Gen and above) *
  • iPad Mini (5th Gen and above)
  • iPad Air (4th Gen and above) *
  • iPad Pro 11 (1st Gen and above) *
  • iPad Pro 12.9 inch (3rd Gen and above) *

Android

  • Samsung Galaxy Tab S series (S6 and above) *
  • Samsung Galaxy Tab A series (A7 10.4-inch and above) *
  • Lenovo M10 Plus (3rd gen and above) *
  • Lenovo P1 Plus *
  • Xiaomi Pad 5 *

Smartphones

iOS

  • iPhone (9 and above)
  • iPhone SE (3rd Gen)

Android

  • Samsung Galaxy S series (S20 and above)
  • Samsung Galaxy A series (A22 and above) 
  • Samsung Galaxy Note Series (20 and above)
  • Oppo Reno Series (3 Pro and above)
  • Xiaomi Mi Series (10 5G and above)

    * Recommended devices for Cogo